Agoraquest Logo
The only place for the Sony Enthusiast Free Member Registration | Login | Contact Us | Quick Search Forum   
Main Menu
  • Home
  • Topics
  • Forums
  • Reviews
  • The Top
  • Web Links
  • File Downloads
  • Photo Gallery
  • Archived Articles
  • Media Center
  • Useful Sections
  • Sony Issues
  • Sony Alerts
  • Senior Members
  • Premium Members
  • eBay Sony Auction
  • Search Site
  • About Us
  • Recommend Us
  • Members List
  • Bookmark this Page

    Additional Features
  • Linking to Us
  • Owner Manuals
  • Calender of Events
  • Contact Us
  • Stock Market
  • Agorasearch
  • Break It Down Blog

  • Sponsors




    Who's Online
    Currently Online
    Visitors:178
    Members:0
    Total of:178 users

    MemberLogged
    Most Online Users
    Visitors:980
    Members:1
    Total of:981 online users
    October 17, 2013, 10:29 pm

    Your Current Status
    You are Anonymous user. Register for free by clicking here.

     Inbox
    Log in to check your private message


      
    Moderated By: claudio
    Agoraquest Forum Index Television Troubleshooting
      
    KDF-50E2000 3 blinking red light. Dashboard
    Replies: 17 | Views: 25,110
    Last Reply: November 8, 2011, 1:57 pm

    View Printable Version of this thread
    Members below have participated in this thread
    claudio | jehill | hilvar | CHITOWN30 | iqbal79 | damonaf | jamesnh70 | seanlove2007 | biv200 | tvalone |
    This thread topic spans 2 pages - You are currently on page 1
    NEXT>> (1 | 2 )
    Search other threads for related issues/solutions: or use Advance Forum Search
    Get the latest Exclusive Sony News by Joining our RSS Feed or Get RSS Via Email
    Author KDF-50E2000 3 blinking red light.
    CHITOWN30

    Rank: Sony Fan


    Joined: Oct 27, 2008
    Posts: 4
    From: US

      Posted: 2008-10-27 13:38

    Hello everyone. Just wondering what it means? The tv will work for a couple hours then go to standby and blink 3 red lights. I  hit the power and tv is back to normal. Any info would be greatly welcome. The TV was purchased in 12/07/06. Also it has the original bulb. Thanks

    Sony KDF-50E2000


       


    hilvar
    Premium Member

    Rank: Sony Fan


    Joined: Oct 27, 2008
    Posts: 5
    From: New York

      Posted: 2008-10-27 13:49

    I don't know if this would apply to your model as I have a KDS-55A2000 but they may be close enough on self-diagnostics.

    On mine 3 red lights is "Lamp cover not attached securely".

    Now I would have thought that if t's not secure then it would not turn on and run for a while - unless you live omewhere where there is a lot of vibration or the sensor itself is faulty.

    I'm kinda new at this so definitely wait for some confirmation from more experienced folks but this may help you get started - checking the lamp cover is real easy after all so you can eliminate that.


       
    jehill
    Premium Member

    Rank: Sony Senior Advisor


    Joined: Mar 13, 2003
    Posts: 14283
    From: Sewell, NJ

      Posted: 2008-10-27 14:37

    If the KDF-50E2000 is a rear projection LCD model, that advise applies.


       
    CHITOWN30

    Rank: Sony Fan


    Joined: Oct 27, 2008
    Posts: 4
    From: US

      Posted: 2008-10-27 14:46

    i just removed the cover and lamp. reattached everything as it was before and now the tv will just blink red 3 times. The Power light turns green for 2 secs then goes to 3 red blinks. The cover is on there tight. Have no idea what else to do.


       
    CHITOWN30

    Rank: Sony Fan


    Joined: Oct 27, 2008
    Posts: 4
    From: US

      Posted: 2008-10-27 16:20

    i think the switch for the door went bad. i took out the switch and pushed the contact down and the TV will still give me the 3 blinking lights. Anybody know what the cost is of this switch?


       
    CHITOWN30

    Rank: Sony Fan


    Joined: Oct 27, 2008
    Posts: 4
    From: US

      Posted: 2008-10-28 11:13

    Just got off the phone with Sony and they have no clue about a lamp door switch. Unreal. But they insisted on sending out a tech. Could not even order the part because it does not exist to them. Now i have to go to some TV shop so they could charge me $60 to put in a $20 switch.


       
    iqbal79

    Rank: Sony Fan


    Joined: Jan 07, 2009
    Posts: 2
    From: u.k

      Posted: 2009-01-07 17:42

    hi i have the same problem i put in a new lamp switched on  then 3 flashing red. im stuck too dont know what to do. 


       
    claudio
    Moderator
    Premium Member

    Rank: Ultimate Sony Reviewer


    Joined: Aug 30, 2001
    Posts: 2359
    From: Rockville, MD

      Posted: 2009-01-07 17:55

    I would be interested to see if there are any updates. Seem like more and more people are getting the 3 flashing light. But the lamp door is closed properly. I wonder if it is the lamp switch door.


         
    claudio
    Moderator
    Premium Member

    Rank: Ultimate Sony Reviewer


    Joined: Aug 30, 2001
    Posts: 2359
    From: Rockville, MD

      Posted: 2009-03-10 18:01

    Hi,

    Did either of you fix the issue of the 3 blinking lights?

    Wanted to see what the TV shop said about it.


         
    jehill
    Premium Member

    Rank: Sony Senior Advisor


    Joined: Mar 13, 2003
    Posts: 14283
    From: Sewell, NJ

      Posted: 2009-03-10 19:41

    News Flash! Much to my surprise I found that I have access to the KDF-50E2000 service manual at Sony Europe.  According to the service manual, 3 blinks, pause, 3 blinks, etc. means "Lamp Protection" and the description is "Lamp Error (Cannot power on after 3 attempts)".  Also, 2 blinks, pause, 2 blinks, etc. means "Lamp Cover" and the description is "Lamp Cover Problem (Possibly Open)".

    My apologies if I mislead anyone by assuming that 3 blinks mean "Lamp Cover", when in fact 2 blinks means that for this model.  If you are getting 3 blinks, I suspect that you need to replace the lamp or possibly the lamp driver.  Since you have never replaced the lamp, I would try that first.


       
    claudio
    Moderator
    Premium Member

    Rank: Ultimate Sony Reviewer


    Joined: Aug 30, 2001
    Posts: 2359
    From: Rockville, MD

      Posted: 2009-03-11 16:44

    Hi Jehill,

    Good catch. I'm starting to see the 3 blink issue more and more. and couldn't figure out why the lamp door would stop working. But "Lamp Protection" looks like it would be the issue. I wish it was the same for the other models.


         
    damonaf

    Rank: Sony Fan


    Joined: Apr 01, 2009
    Posts: 3
    From: Alabama

      Posted: 2009-04-01 21:04

    Just thought i'd share my solution.

    I had the same problem (KDF-46E2000). I replaced my lamp, installed the lamp cover properly and still had the problem. I took the lamp out again and noticed a switch at the very back ( kinda like the lamp door switch.) I played with the contact on that switch (pulled the contact out a little.....without removing it) and reinstalled the lamp and lamp door and BAM!!! TV was working again. Haven't had any more issues yet. Let's see how long it lasts.



       
    jamesnh70

    Rank: Sony Fan


    Joined: Apr 08, 2009
    Posts: 1
    From:

      Posted: 2009-04-08 19:42

    I experienced the same problem. Just like the post previous mine, I determined that the Lamp module switch bracket had become loose. I actually took my TV apart, and tightened the screw that holds the bracket in. You have to carefully remove the "G" board (I just unhooked the cables on the left side and four screws, plus the shiny silver ones on the bottom on "G") There is only one screw that holds this bracket on, and mine had swung away from the module.  I saved that $450 service call, and that makes me HAPPY!!  


       
    claudio
    Moderator
    Premium Member

    Rank: Ultimate Sony Reviewer


    Joined: Aug 30, 2001
    Posts: 2359
    From: Rockville, MD

      Posted: 2009-04-09 11:55

    Hi Jamessnh70 and damonaf,

    Great job. Seems like people are starting to get this issue when they replace their lamp.


         
    seanlove2007

    Rank: Sony Fan


    Joined: Apr 09, 2009
    Posts: 2
    From: Wesley Chapel, Florida

      Posted: 2009-04-09 16:51

    had same issue on my 60 inch rear-projection, replaced lamp and secured door and everything is working well.




       
    This topic thread spans 2 pages - You are currently on page 1
    NEXT>> (1 | 2 )


    Advance Features
      
    Jump To:
    Locations 
of visitors to this page


    All logos and information in this site are property of their respective owner. The comments are property of their posters. This website www.agoraquest.com, Claudio Meira and Agoraquest, LLC is not tided in any form to the Sony Corporation (www.sony.com). This unoffical website is just place where Sony products are reviewed among the general public. Sony is a registered of Sony, Inc. "PlayStation", "PlayStation2", the PlayStation "PS" logo, and all associated logos/graphics. "Agoraquest, LLC" and "agoraquest.com" are associated exclusively with agoraquest.com, and are NOT associated in ANY way with Sony Electronics, Inc. To view the privacy policy, please click here and to view the terms of use, please click here. If you have any further questions, please contact using our online form.