Agoraquest Logo
The only place for the Sony Enthusiast Free Member Registration | Login | Contact Us | Quick Search Forum   
Main Menu
  • Home
  • Topics
  • Forums
  • Reviews
  • The Top
  • Web Links
  • File Downloads
  • Photo Gallery
  • Archived Articles
  • Media Center
  • Useful Sections
  • Sony Issues
  • Sony Alerts
  • Senior Members
  • Premium Members
  • eBay Sony Auction
  • Search Site
  • About Us
  • Recommend Us
  • Members List
  • Bookmark this Page

    Additional Features
  • Linking to Us
  • Owner Manuals
  • Calender of Events
  • Contact Us
  • Stock Market
  • Agorasearch
  • Break It Down Blog

  • Sponsors




    Who's Online
    Currently Online
    Visitors:157
    Members:2
    Total of:159 users
    MemberLogged
    mhedges0.0 min
    jttar8.1 min
    Users will be removed if they logged out or are inactive for 35 minutes

    Most Online Users
    Visitors:980
    Members:1
    Total of:981 online users
    October 17, 2013, 10:29 pm

    Your Current Status
    You are Anonymous user. Register for free by clicking here.

     Inbox
    Log in to check your private message


      
    Moderated By: claudio
    Agoraquest Forum Index Television Troubleshooting
      
    Sony KF50WE610, no Pic, 5 red power blinks Dashboard
    Replies: 8 | Views: 5,496
    Last Reply: October 1, 2009, 8:54 pm

    View Printable Version of this thread
    Members below have participated in this thread
    claudio | jehill | KRP66 | SGW50 |
    Search other threads for related issues/solutions: or use Advance Forum Search
    Get the latest Exclusive Sony News by Joining our RSS Feed or Get RSS Via Email
    Author Sony KF50WE610, no Pic, 5 red power blinks
    KRP66

    Rank: Sony Fan


    Joined: Sep 05, 2008
    Posts: 5
    From: Atlanta

      Posted: 2008-09-05 18:16

    All,

    I have seen many post on this issue and it sounds like I need to replace the lamp and the lamp driver board. I live in the Atlanta area and wanted to see if someone can help on where I can get the parts and the service manual.

    KF-50WE610. Turn power on. Green light flashes a few times then turns red after a buzzing sound. Red light flashes 5 times each round. This is the Standbye lamp. No other lights come on. Picture stays black..


    Are these the parts below.

    1. The Service manual Sony P/N 996537703, SM KF42WE610/50/60 03 US CAN, originally $12.74, which now appears to cost $23.29.
    <o></o>



    2. Lamp Driver Board, The current Sony P/N for the lamp driver board appears to be
    146879816 for $116.25.


    3. Lamp XL-2100U for $200???

    Please recommend where to get the parts. Thanks ahead for any help!

    -Kevin


       


    KRP66

    Rank: Sony Fan


    Joined: Sep 05, 2008
    Posts: 5
    From: Atlanta

      Posted: 2008-09-05 18:20

    By the way, my email is clicking here)

    (Email Address will not display unless member has 100 posts or is a Premium Member, see the great benefits premium member have by clicking here)
    />
    Thanks!


       
    claudio
    Moderator
    Premium Member

    Rank: Ultimate Sony Reviewer


    Joined: Aug 30, 2001
    Posts: 2359
    From: Rockville, MD

      Posted: 2008-09-05 18:24

    Hi KRP66,

    There are a lot of places to get the lamp parts but the official one is at

    http://servicesales.sel.sony.com/ecom/accessories/web/index.jsp

    To replace the lamp, below is a thread that has details on how to do it.

    http://www.agoraquest.com/viewtopic.php?topic=31722&forum=70&keyword2=electronics

    There is a thread on the five blinks at

    http://www.agoraquest.com/viewtopic.php?topic=22397&forum=34


    Part No.        Description                                Price (USD)
    996537703    SM KF42WE610/50/60 03 US CAN   $12.74
    146879811    LAMP POWER SUPPLY BLOCK         $116.25


         
    KRP66

    Rank: Sony Fan


    Joined: Sep 05, 2008
    Posts: 5
    From: Atlanta

      Posted: 2008-09-05 21:11

    Do you know of a thread to change out the lamp driver board? I am trying to locate it.. Thanks for the reply..


       
    KRP66

    Rank: Sony Fan


    Joined: Sep 05, 2008
    Posts: 5
    From: Atlanta

      Posted: 2008-09-05 21:42

    Ah... I think I found it. rear of TV behind a metal shield.


       
    jehill
    Premium Member

    Rank: Sony Senior Advisor


    Joined: Mar 13, 2003
    Posts: 14279
    From: Sewell, NJ

      Posted: 2008-09-06 08:07

    It wouldn't be a bad idea to obtain the "Lamp-Driver SB including lamp driver removal drawings/KF42WE610, KF50WE610, KF60WE610" information package available, because there are HV wire dressing instructions that you should follow.  See the FAQ forum "Television Troubleshooting Information Packages" thread for instructions.  You must become a premium member.


       
    KRP66

    Rank: Sony Fan


    Joined: Sep 05, 2008
    Posts: 5
    From: Atlanta

      Posted: 2008-09-09 20:15

    Lamp Driver Board did the job. I ordered the new lamp as well since the one I have is 4 years old. The only issue I had was the lamp driver board. I am using the original lamp when i bought the TV. I did see the HV wires and put them back exactly the way they were before. Looks like all is good to go.. Thanks for the info and help!!


       
    jehill
    Premium Member

    Rank: Sony Senior Advisor


    Joined: Mar 13, 2003
    Posts: 14279
    From: Sewell, NJ

      Posted: 2008-09-09 20:51

    Exactly as they were before isn't what's recommended for the wire dressing, but hey, if it ain't broke, don't fix it!


       
    SGW50
    Premium Member

    Rank: Sony Fan


    Joined: Sep 26, 2009
    Posts: 5
    From: Burr Oak, MI

      Posted: 2009-10-01 20:54

    • Member Quote

    On 2008-09-09 20:15, KRP66 wrote:
    Lamp Driver Board did the job. I ordered the new lamp as well since the one I have is 4 years old. The only issue I had was the lamp driver board. I am using the original lamp when i bought the TV. I did see the HV wires and put them back exactly the way they were before. Looks like all is good to go.. Thanks for the info and help!!



    Was your TV a KF50WE610? If so do you have a picture or diagram showing the routing of the high voltage antenna that is looped right above the lamp driver board.?

    Dave


       
    Advance Features
      
    Jump To:
    Locations 
of visitors to this page


    All logos and information in this site are property of their respective owner. The comments are property of their posters. This website www.agoraquest.com, Claudio Meira and Agoraquest, LLC is not tided in any form to the Sony Corporation (www.sony.com). This unoffical website is just place where Sony products are reviewed among the general public. Sony is a registered of Sony, Inc. "PlayStation", "PlayStation2", the PlayStation "PS" logo, and all associated logos/graphics. "Agoraquest, LLC" and "agoraquest.com" are associated exclusively with agoraquest.com, and are NOT associated in ANY way with Sony Electronics, Inc. To view the privacy policy, please click here and to view the terms of use, please click here. If you have any further questions, please contact using our online form.