[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 35: Use of undefined constant topic - assumed 'topic' (this will throw an Error in a future version of PHP)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4777: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3912)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4779: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3912)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4780: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3912)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3912)
Agoraquest • View topic - Is it worth repairing my TA-F770 ES? Any good UK repairers?

        Advanced search
It is currently Wed Jan 20, 2021 3:32 am
Please Login or Register to take advantage of all of our forum benefits.

View topic - Is it worth repairing my TA-F770 ES? Any good UK repairers?

Is it worth repairing my TA-F770 ES? Any good UK repairers?

This forum addresses questions on installation, configuration and troubleshooting you might encounter with your Sony Amp/Receiver/Speakers/Connections/Cables.

Moderator: jttar

by SubmarinerUK » Sat Mar 24, 2018 3:11 pm

Oh a sad day
It looks like my 1990 darling has blown the right channel.

I was using it to power two 4Ohm big subs.
Not its intended purpose, but hey it worked perfectly since 2007.

I used a Y splitter from the TA 7100ES sub woofer RCA leads.
And today no sound on the right channel :(:(:(

If it could be repaired for a reasonable cost, and partly out of sentiment I would do it if I could find someo e who would use quality components.

What do you think is it repairable?

Any recommendations for any genuius repairers who could me d it and give it a clean?

Or shou,d I just go and look for a new power amp, likewise any reccomendations?
Must be able to drive 4 Ohms ... note these subs were voted as exceptionally musical.
Must be at least 180 watts , 2 channel THD 0.02 % SN 105

Any help appreciated
Peter
User avatar
SubmarinerUK
Sony Fan
Sony Fan
 
Posts: 5
Joined: Thu Oct 02, 2014 6:14 am

by jttar » Sun Mar 25, 2018 4:23 pm

Hello SubmarinerUK,

My guess is that one or more surface mount resistors have gone bad. This is not something an unexperienced person would want to try. If it were me, I'd bring it into an electronic repair shop and ask for estimate of repairs. This can help you decide if it is worth repairing or replacing. Expect to pay at least half a hundred for the tech's testing time.

Joe
User avatar
jttar
Sony Legend
Sony Legend
 
Posts: 9043
Joined: Thu Feb 27, 2003 8:00 pm
Location: Chicago,IL, USA

by SubmarinerUK » Sun Mar 25, 2018 7:52 pm

Thanks Joe
No problem paying for it. The difficulty is finding someone really skilled, who can fix it.

I also wonder was this my fault ... OK its 28 years old .. would you believe it!

Reason:
Rather than throw it away when it was working beautifully.
I took advice from Sony technical,
Could I use a Y splitter, to get two RCA leads from the one SUB out on the STR DA7100ES.
The output from the Sony was 2V 1kohm.
The input on the TA 770 ES was 150mV 20 kohms.
They said that would be OK and would not damage the 7100 ES output or the 770 ES input. The latter has a single 4 Ohm 10” 400W Soundstream Exact Subwoofer on each.
And they ran happily of 9 years.
Wouldnthat have blown a channel?

Or is it just age. .. ot died.

No complaints 28 years is nothing short of fantastic.
User avatar
SubmarinerUK
Sony Fan
Sony Fan
 
Posts: 5
Joined: Thu Oct 02, 2014 6:14 am

by jttar » Wed Mar 28, 2018 9:08 pm

I doubt that did any damage. My guess is just fair wear and tear on the electronics. I have an old mom and pop electronics shop by me that I can still go to, not that it helps you but maybe you could do some investigating and find a shop close by. Best of luck and let us know if you find someone.

Joe
User avatar
jttar
Sony Legend
Sony Legend
 
Posts: 9043
Joined: Thu Feb 27, 2003 8:00 pm
Location: Chicago,IL, USA

by Maxxwire » Sat Mar 31, 2018 1:00 am

Sony TA-F770ES.jpg
Sony TA-F770ES.jpg (116.24 KiB) Viewed 7215 times


Submariner- Sorry to hear that your TA-F770ES is ailing. As far as getting it fixed you might be able to find a local shop that sells used Audio gear and find out if they have a tech onsite that could service your classic Sony integrated amp. We have 2 such shops here in town that each employ a full time technician to service the used Audio gear that goes through their shop.
Image

Image

User avatar
Maxxwire
Sony Adept
Sony Adept
 
Posts: 26223
Joined: Wed Aug 28, 2002 8:00 pm
Location: Portland, Oregon - USA


Return to Amp/Receiver/Speakers/Connections/Cables