[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 35: Use of undefined constant topic - assumed 'topic' (this will throw an Error in a future version of PHP)
Agoraquest • View topic - Confused about HDMI and ARC--No sound from internet streaming on new TV

        Advanced search
It is currently Sat Dec 14, 2019 3:26 am
Please Login or Register to take advantage of all of our forum benefits.

View topic - Confused about HDMI and ARC--No sound from internet streaming on new TV

Confused about HDMI and ARC--No sound from internet streaming on new TV

This forum addresses questions on any installation problems you might encounter with your Sony television (i.e. How to install, what wires go where, etc.)

Moderator: jttar

by pathologymd » Fri Jul 29, 2011 4:19 pm

Hello,

I am mightily confused right now.  Last week I bought new Sony A/V receiver (STR-DH820), and today the new TV arrived (Bravia 55HX820).  I have two HDMI inputs to the receiver, Sony Blu-Ray and DirecTV receiver.  The output of the A/C receiver is connected to the TV through HDMI (ARC) on both ends.  Now, I used to stream Amazon video through the Blu Ray player with no issues (and still can).  However, after setting up wifi successfully on the TV and attempting to play streaming video, I get picture but no sound.  If I understand, the audio generated by the TV is fed back to the receiver via the ARC in the HDMI cable.  I don't understand how to "access" this audio.  If I have either external source on, such as the DirecTV receiver, I hear it instead of the audio from the streaming video.  If I cut the other source off, great picture but no audio.  I tried changing the input of the A/V receiver to "TV" to no avail.

I haven't tried a separate optical cable yet, I thought that was the purpose of ARC.  And supposedly any HDMI cable will do regarding ARC.

Someone please enlighten me.
William

pathologymd
Sony Buff
Sony Buff
 
Posts: 14
Joined: Tue Jun 21, 2005 8:00 pm
Location: Madison, Mississippi

by jehill » Sat Jul 30, 2011 2:29 pm

It sounds like you have the HDMI cable between the TV and A/V receiver connected properly.  Are there receiver settings associated with the ARC input?  You should be able to get the audio output for any input selelcted on the TV via the ARC connection if you have TV selected on the A/V receiver.
User avatar
jehill
Sony Senior Advisor
Sony Senior Advisor
 
Posts: 14207
Joined: Wed Mar 12, 2003 8:00 pm
Location: Sewell, NJ

by jehill » Sun Jul 31, 2011 4:15 am

You should review the "BRAVIA" Sync Features section of the Operating Instructions.  There is a section "enjoying the TV sound from the speakers connected to the receiver (System Audio Control) on p-61.  Another thing that you might do is search the Operating Instructions for "arc" and look at each of the hits for information that may help.
User avatar
jehill
Sony Senior Advisor
Sony Senior Advisor
 
Posts: 14207
Joined: Wed Mar 12, 2003 8:00 pm
Location: Sewell, NJ

by pathologymd » Sun Jul 31, 2011 6:43 am

Thanks, I really appreciate your responses.  The only caveat I can find states that you must enable "control for HDMI."  It is enabled on all the items (all new Sony) that I have.  I did see a reference on the Sony website that said to make sure that "return audio channel" is set to ON in the A/V receiver.  I cannot find that in this receiver.  I emailed Sony, and the response didn't help (told me what I already knew).  I have tried different audio menu settings to no avail.  So, I am going to try a newer HDMI cable (on order) to see if this cable is bad.  Long shot I know.  I would substitute another of my HDMI cables, but none are long enough.

I also ordered a Toslink cable as a backup in case I can't get this to work through the ARC.

Thanks,

William
pathologymd
Sony Buff
Sony Buff
 
Posts: 14
Joined: Tue Jun 21, 2005 8:00 pm
Location: Madison, Mississippi

by jehill » Mon Aug 01, 2011 2:32 pm

The whole purpose of ARC is to eliminate the need for a separate Toslink cable.
User avatar
jehill
Sony Senior Advisor
Sony Senior Advisor
 
Posts: 14207
Joined: Wed Mar 12, 2003 8:00 pm
Location: Sewell, NJ

by pathologymd » Mon Aug 01, 2011 4:14 pm

I couldn't agree more.  The toslink cable is my fall-back if I can't get the ARC to work.  I sent another email to Sony and they want me to call in and troubleshoot real-time.  I am going to call when I confirm that the problem is not with the HDMI cable.  A new cable will be here Wednesday.
pathologymd
Sony Buff
Sony Buff
 
Posts: 14
Joined: Tue Jun 21, 2005 8:00 pm
Location: Madison, Mississippi

by jehill » Tue Aug 02, 2011 11:27 am

I doubt that the problem is the cable, but who knows?
User avatar
jehill
Sony Senior Advisor
Sony Senior Advisor
 
Posts: 14207
Joined: Wed Mar 12, 2003 8:00 pm
Location: Sewell, NJ

by pathologymd » Tue Aug 02, 2011 12:34 pm

OK the verdict is in.

The new cables got here from Amazon a day early.  It was the HDMI cable between the receiver and TV.  I also noticed that when I turned on the TV, the receiver came on automatically through Bravia sync which it had not done before.  Also, when switching the TV to internet content, the receiver automatically switched to TV, WITH audio.  Amazing that the other cable worked so well regarding picture and audio, but not Bravia sync and ARC.  I know they say HDMI cables are all the same, but I wonder if some manufacturers did not wire all pins in the earliest versions.  I don't recall where I got that HDMI cable, but it is a "no name."

An internet search also found other cases of some ARC cable dependency.

William
pathologymd
Sony Buff
Sony Buff
 
Posts: 14
Joined: Tue Jun 21, 2005 8:00 pm
Location: Madison, Mississippi


Return to Television Installation

cron